Ciko

Forum Icons 2.0.1

20 сообщений в этой теме

Forum Icons 2.0.1


Становите компонент

Потом делаем небольшую правку стиля:

Зайдите в ACP - Внешний вид -> Ваш Стиль -> Список форумов -> boardIndexTemplate

Найти:

<td class='col_c_icon'>
			 <if test="hasUnread:|:$forum_data['_has_unread']">
			 <a id='forum_img_{$forum_data['id']}' href="{parse url="app=forums&module=forums&section=markasread&marktype=forum&forumid={$forum_data['id']}&returntoforumid={$this->request['f']}&i=1" base="public"}" data-tooltip="{$this->lang->words['bi_markread']}" class='forum_marker'><img src='{$this->settings['img_url']}/f_icon.png' /></a>
			 <else />
			 <img src='{$this->settings['img_url']}/f_icon_read.png' />
			 </if>
		 </td>
Заменить на:
<td class='col_c_icon'>		
			 <if test="hasUnread:|:$forum_data['_has_unread']">
			 <a id='forum_img_{$forum_data['id']}' href="{parse url="app=forums&module=forums&section=markasread&marktype=forum&forumid={$forum_data['id']}&returntoforumid={$this->request['f']}&i=1" base="public"}" data-tooltip="{$this->lang->words['bi_markread']}" class='forum_marker'><if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon.png' /></if></a>			
			 <else />
			 <if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon_read.png' /></if>
			 </if>
		 </td>

 


 

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Developer сказал:

А что по поводу иконки f_redirect.png?
Это иконка форума-ссылки, она теперь не отображается.

А картинка у тебя вообще била или нет? ёсли нет загрузи.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
32 минуты назад, Developer сказал:

Она и была, и есть, но не выводится:

Безымянный.jpg

Измени цвет икони.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
8 часов назад, Developer сказал:

Не помогло.

У тебя часто что-то не получается. Может дело в твоих руках?

Не задумывался нанять себе человека, чтоб шаблон нарисовал и сверстал? Коль у тебя не получается все по  готовой инструкции сделать.

Я бы на твоем месте задумался, стоит ли заниматься тем, что ты не понимаешь.

Скажу тебе так, я когда начинал, тоже не чего не понимал. Уделил неделю подробному FAQ , усвоил все. и теперь не задаю глупых вопросов. Так же, можешь начать изучать html, php, css - php тебе пока что не понадобиться конечно. но все равно, когда нибудь знания эти тебе пригодятся.

1 пользователю понравилось это

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 16.10.2015 в 18:16, Ciko сказал:

Forum Icons 2.0.1


Становите компонент

Потом делаем небольшую правку стиля:

Зайдите в ACP - Внешний вид -> Ваш Стиль -> Список форумов -> boardIndexTemplate

Найти:


<td class='col_c_icon'>
			 <if test="hasUnread:|:$forum_data['_has_unread']">
			 <a id='forum_img_{$forum_data['id']}' href="{parse url="app=forums&module=forums&section=markasread&marktype=forum&forumid={$forum_data['id']}&returntoforumid={$this->request['f']}&i=1" base="public"}" data-tooltip="{$this->lang->words['bi_markread']}" class='forum_marker'><img src='{$this->settings['img_url']}/f_icon.png' /></a>
			 <else />
			 <img src='{$this->settings['img_url']}/f_icon_read.png' />
			 </if>
		 </td>

Заменить на:

<td class='col_c_icon'>		
			 <if test="hasUnread:|:$forum_data['_has_unread']">
			 <a id='forum_img_{$forum_data['id']}' href="{parse url="app=forums&module=forums&section=markasread&marktype=forum&forumid={$forum_data['id']}&returntoforumid={$this->request['f']}&i=1" base="public"}" data-tooltip="{$this->lang->words['bi_markread']}" class='forum_marker'><if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon.png' /></if></a>			
			 <else />
			 <if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon_read.png' /></if>
			 </if>
		 </td>

 


 

А как добавить или изменить иконку?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, Dragonel сказал:

Для IPS4 есть?

На IPS это стандартная функция. Сначала бы скачали, разобрались, а потом бы начали создавать свой проект на данном cms. Глупые вопросы бы не задавали..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
14 часа назад, Ded Moroz сказал:

На IPS это стандартная функция. Сначала бы скачали, разобрались, а потом бы начали создавать свой проект на данном cms. Глупые вопросы бы не задавали..

для этого и был создан сайт ваш что бы помогать людям а не показывать свой характер, если лень помочь мог бы и промолчать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
14 часа назад, Ded Moroz сказал:

На IPS это стандартная функция. Сначала бы скачали, разобрались, а потом бы начали создавать свой проект на данном cms. Глупые вопросы бы не задавали..

уже разобрался

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 часа назад, Dragonel сказал:

для этого и был создан сайт ваш что бы помогать людям а не показывать свой характер, если лень помочь мог бы и промолчать.

Я тебе помог, разве нет? Я тебе сказал, что это стандартная функция. Это ты не благодарный, тебе помогли, а ты из себя обиженного строишь. Никто свой характер не показывал, тебе просто совет дали. Научись правильно анализировать контекст (это тоже мой совет тебе)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Ded Moroz сказал:

Я тебе помог, разве нет? Я тебе сказал, что это стандартная функция. Это ты не благодарный, тебе помогли, а ты из себя обиженного строишь. Никто свой характер не показывал, тебе просто совет дали. Научись правильно анализировать контекст (это тоже мой совет тебе)

Спасибо уже разоюрался

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не могу установить мод хоть убейте, залил папку uploads через  FileZilla в папку .cache (файлы загрузились без ошибок), но когда захожу в АЦ  > Управление приложениями и........ нет там никаких неустановленных приложений. Что я делаю не так? Сразу скажу что познания в  html, php, css - php у меня самые поверхностные, на уровне "чайника", так что если что тролить не надо, просто протяните руку помощи если знаете в чем причина:chih:   Форум создан на движке IPB 3.4.9.  Спасибо.

 

 

Screenshot_1.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В папке Upload вижу две папки: uploads и admin, папки  pablic нет, извините может я вовсе тупой но объясните что я делал не так, я так понимаю что бы залить файл в корень форума мне нужно  FileZilla, я беру папку upload и перетаскиваю ее в папку .cache, идет загрузка файлов, или я что то не правильно делаю? Как правильно загружать файлы в корень сайта, может объясните? Спасибо.

Screenshot_2.thumb.png.d624b2ac97d26b2cd7e3e672cf138b8b.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В том то и дело что я делаю все согласно инструкции, файлы с папки upload все загружаются (пишет "Передача успешная") а перехожу в АЦ > Управление приложениями,  не загруженных приложений не появляется, уже голову сломал, что не так не могу понять:omg:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зареєструвати аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу

Яндекс.Метрика Рейтинг@Mail.ru Индекс цитирования